[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unable to resume screen session following accidental disconnection

From: Samir Unni
Subject: Re: Unable to resume screen session following accidental disconnection
Date: Thu, 3 Jul 2008 14:05:24 -0500

Actually, when it happened to me a second time a little while later, 'screen -x [session name]' would not work. I just had to wait for something (don't know exactly what) to time out.

On Thu, Jul 3, 2008 at 11:04 AM, Samir Unni <address@hidden> wrote:
I just ran into the same issue, and 'screen -x [session name]' worked perfectly. Thanks for the tip!

On Wed, Jul 2, 2008 at 3:22 PM, Samir Unni <address@hidden> wrote:
No, I haven't. I'll try it the next time I encounter this problem. Turns out that when I let it sit for about 10 minutes, the session finally appears.

On Wed, Jul 2, 2008 at 3:21 PM, <address@hidden> wrote:
I use screen -x to attach to an attached session, have you tried this?

On 02/07/2008, Samir Unni <address@hidden> wrote:
> Hi,
> I was using screen, and my session was disconnected while outputting a lot
> of text (presumably due to a router choking---the upwidth for the remote box
> is pretty low, only about 13 kB/s). When the line was back up, I attempted
> to resume my screen session, but it was already attached (presumably because
> the connection was dropped unexpectedly). However, none of the commands I
> try, including screen -r [pid], screen -d [pid], screen -R [pid], screen -D
> [pid], screen -rD [pid], screen -RD [pid], screen -rd [pid], and screen -Rd
> [pid] will reattach this session. I tried running an strace on the pid, and
> it says that it's still outputting text. After waiting a while, I somehow
> managed to get the sesion to reattach---I'm not sure how. The problem
> occured again shortly afterwards, and I can't figure out how to actually fix
> it. Any ideas?
> Thanks,
> Samir Unni

reply via email to

[Prev in Thread] Current Thread [Next in Thread]