[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Two little features (and a bounty?)

From: Dan Mahoney, System Admin
Subject: Re: Two little features (and a bounty?)
Date: Fri, 25 Jul 2008 13:50:24 -0400 (EDT)
User-agent: Alpine 1.10 (BSF 962 2008-03-14)

On Fri, 25 Jul 2008, Micah Cowan wrote:

Yes, I'm top-posting...but it's relevant.

So from Micah's findings, it would almost appear that based on the application, there's a number of things that one needs to do to make this work. (xterm value, fake display, manually send the escape sequence, etc).

This is definitely something that fits well into some kind of documentation grid as to what-setup-requires-what...

I'm not sure if there's anything in screen that can fix it (although I think the window-title hack is a neat answer). I am also not sure if this should be brought to the nano/alpine/whatnot developers -- there are at LEAST a couple situations where you want a mouse without a display, i.e. console-access, where screen is ideal (but then, you have multiple virtual consoles).

Let me think on this a bit more -- there's GOT to be a clean way to handle this -- Micah, do you think it's relevant to open bugs with the appropriate projects?

Or better still, can we come up with a way to define a "test case" for mouse under screenable events?

(I had a coworker tell me I should run gpm in my ssh session, to fix this...I wonder how right he might have been...other than that I'm under freeBSD).

Hash: SHA1

Okay, so here's what I've found.

I confirmed that nano and alpine get mouse events outside screen (duh).

I confirmed that alpine _works_ with mouse inside screen, no problems. I
have to set DISPLAY to a fake value, but I had to do that to make it
work outside of screen, too.

I confirmed that nano does _not_ work by default inside of screen. It
doesn't send the "send mouse events" sequence (it sends the \E[?1000h
sequence outside of screen). If I tell screen to send mouse events
anyway, nano -m doesn't process them correctly (clicking in the editor
pane brings up the help screen, instead of just moving the cursor). To
get screen to send mouse events, I did:

 $ printf '\033[?1000h'; nano -m

You'll want to do a

 $ printf '\033[?1000l'

Sometime afterwards to disable the mouse events again.

BTW, I confirmed that, on my home system, nano under screen doesn't work
for me either. However, when I was at work, it worked fine. I just ssh'd
in and verified it works fine. The version for the one that worked is
1.3.<something> on RedHat, yours is 2.0.7, and mine is 2.0.6.


 $ TERM=xterm nano -m

works fine for me in screen.

- --
Micah J. Cowan
Programmer, musician, typesetting enthusiast, gamer,
and GNU Wget Project Maintainer.
Version: GnuPG v1.4.6 (GNU/Linux)
Comment: Using GnuPG with Mozilla -



"You're a thucking reyer!"

-Richard Bozzello, who believed tongue piercing was painless.

--------Dan Mahoney--------
Techie,  Sysadmin,  WebGeek
Gushi on efnet/undernet IRC
ICQ: 13735144   AIM: LarpGM

reply via email to

[Prev in Thread] Current Thread [Next in Thread]