[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: when running vim under Solaris, terminal doesn't refresh properly

From: Micah Cowan
Subject: Re: when running vim under Solaris, terminal doesn't refresh properly
Date: Fri, 10 Apr 2009 10:45:50 -0700
User-agent: Thunderbird (X11/20090318)

Hash: SHA1

Langella Raphael wrote:
> Hi, I'm running GNU Screen 4.00.02 under Linux RHEL 4u5. vim works
> fine under Linux, but if I ssh to a Solaris machine from within
> screen, then I've got some problem with vim. When I edit a file, I've
> got some garbage after the end of line. Characters from the file I'm
> editing are properly displayed, but when the line is short and
> doesn't fill up my screen, the end is not cleared, I see some
> leftovers from my shell session or from previous vim edit. I've tried
> to change the term to xterm, sun-color or the default screen-bce, but
> it's the same. I've tried with vim 6.3 and the latest 7.2, same
> problem. I'm not sure if the problem comes from screen or vim or
> Solaris. I've also tried to google for it, but I find this problem
> very hard to describe with keywords. Some directions would be greatly
> appreciated. Thanks for your attention.

The most likely culprit is faulty terminfo or termcap definitions.

A useful piece of information would be for you to play around on vim on
Solaris, but not under screen, to see if there's a change in behavior.
If it still has problems (not necessarily the same ones), then it's an
issue with Solaris' terminfo description for your terminal type (what
_is_ your terminal, gnome-terminal?); otherwise, it's probably an issue
with the terminfo description for screen (assuming there is one).

When you ssh into Solaris, what does

  $ echo $TERM

give you, both inside, and outside, of screen?

- --
Micah J. Cowan
Programmer, musician, typesetting enthusiast, gamer.
Maintainer of GNU Wget and GNU Teseq
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla -


reply via email to

[Prev in Thread] Current Thread [Next in Thread]