[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: wall linux command not working?

From: Chris Jones
Subject: Re: wall linux command not working?
Date: Sun, 01 Jan 2012 16:06:44 -0500
User-agent: Mutt/1.5.18 (2008-05-17)

On Sun, Jan 01, 2012 at 10:41:36AM EST, Vladimir Todorov wrote:

> | Were you trying to tell your users they should go home & celebrate the
> | New Year...?

> Haha. I was just trying to find a way to broadcast a message stating
> that something has happened (like an event). The 'wall' command works
> fine for the terminals outside screen. But if we say I have two
> regions in screen with two terminals. And if I execute the 'wall'
> linux command (not :wall in screen) in one of the terminals then the
> message is not shown in the second terminal in the second region (in
> the same screen session). But the message is shown on the terminals
> that are not running in screen. I tried to execute 'wall' in
> a terminal outside screen and the messages is again visible on all
> terminals not running in screen and not visible on all terminals
> running in screen. It's strange. It doesn't matter if I execute 'wall'
> with root or with my regular user - the message is not shown in either
> case. 

> I am using Debian 6 Squeeze with 2.6.39-bpo.2-686-pae kernel from

Hmm.. that's odd. Since quite obviously (at least that's the way I see
it..) the superuser should be able to send a message to all users at any
time regardless of whatever options they have set that might block
messages from unprivileged users, I vagueley thought that what might be
causing this was that you were logged in as an unprivileged user when
you experienced the problem. Seems to be more to it than that.

This is the version of GNU screen I am running (more recent than the one
that comes with ‘lenny’):

| $ screen -v
| Screen version 4.01.00devel (GNUa6eea7b) 2-May-06

In the test I ran, I su'd to root in a bash session running within
screen and issued the ‘wall’ command. Then I typed ‘hello’ followed by
<Enter> and then CTRL-D to exit back to the shell & actually send the

As expected, and regardless of what apps they were running, all the
screen ‘terminals’ within my screen session (including the root shell
I had sent the broadcast from), a couple of xterms running outside
screen, and the linux console from which I had started my X11 session

| Broadcast Message from address@hidden
|         (/dev/pts/1) at 15:26 ...
| hello

Might be worth checking the permissions on the pseudo terminals:

| $ ls -al /dev/pts/

Of course, I can't see what you are actually doing, and maybe there is
an outside chance that the message does get written to what you call the
‘second screen region’ but that switching from region #1 (where you
issued the wall command) to region #2 causes the message to disappear
before you get a chance to see it. Something that wouldn't happen if you
were sending the message to s/o else.

You could try hitting ‘CTRL-A [’ to switch screen to ‘copy mode’ and
scroll up via, e.g. CTRL-U, see if you find your message?

Since I understand that you have several users (physical users,
I assume) logged on to the same machine, would it make sense to test
this with two ‘physical terminals’ or even with two separate X11
sessions (on the same machine) on vt7/vt8..?

Otherwise, I'm not sure what's going on, but I thought I'd give
a detailed account of the way I ran my test anyway, just in case.. 

Maybe someone more familiar with quirks relative to IPC and such on
linux will be able to hazard a guess?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]