[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Detached sessions not being created

From: Mark Adams
Subject: Detached sessions not being created
Date: Thu, 22 Nov 2012 19:35:01 -0700

I have several machines on my network that provide services of one type or another. I'm trying to configure them to create detached screen sessions at boot time. Let's take a representative example.

I have a cron job setup under my user ID:

@reboot /usr/bin/screen -d -m -S pvr

I have also used the syntax "@reboot /usr/bin/screen -dmS pvr".

Neither of these has worked.

I tried creating a bash script:

# This script starts a detached screen session on boot.
su - <my_user> -c "/usr/bin/screen -dmS pvr"

Neither of these work despite the fact that when I run the command "/usr/bin/screen -d -m -S pvr" as my user in a konsole window it creates the screen session as expected (note that I can stack those options to -dmS and it makes no difference).

I should say that I'm also unable to start that screen session from crontab in Webmin (I assume it uses the run-parts command to do that). I get no error - it just doesn't create the screen session.

I set uid root: "chmod a+s /usr/bin/screen" and I have seen references to changed the permissions of /var/run/screen.  I have no /var/run/screen.

Any wisdom?


Mark Adams

reply via email to

[Prev in Thread] Current Thread [Next in Thread]