[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Scrollback and other commands don't work

From: Jürgen Weigert
Subject: Re: Scrollback and other commands don't work
Date: Thu, 17 Apr 2014 21:07:17 +0200

Let me through you some random questions. Maybe that sheds some light on the issue.
Within a screen session, if you do
  C-A i
it should show you something like this

(27,5)/(87,38)+3333 +flow UTF-8 0(bash)

where 3333 is my scrollback. Do you see a 0 instead?

If so, does it change, if you do from within the screen sessio
  C-a : scrollback 456

cheers, JW-

On Thu, Apr 17, 2014 at 8:59 PM, Alex <address@hidden> wrote:
Hi guys,

On Mon, Apr 14, 2014 at 6:01 PM, Jürgen Weigert <address@hidden> wrote:
One more note: There could also be a compile time limit.
If you can grab the source of your fc20 screen version, check out this:

$ grep MAXHISTHEIGHT src/*
src/screen.h:#define MAXHISTHEIGHT        3000

Just to be safe, I reduced it to 1000, and it still had no effect. No scrollback whatsoever.

I also removed my local ~/.screenrc and even then tried removing the /etc/screenrc, and it had no effect.

I also compiled the latest git snapshot, and still no scrollback. I didn't even try and figure out the other problems since even scrollback didn't work.

I does recognize some of my ~/.screenrc settings, including my keybindings. Could it have something to do with my version of gnome-terminal? Scrollback works in the terminal alone, when screen isn't running...

Any further ideas greatly appreciated.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]