[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Simulavr-devel] Re: comments on documentation

From: Michael Hennebry
Subject: [Simulavr-devel] Re: comments on documentation
Date: Sun, 27 Apr 2008 11:32:19 -0500 (CDT)

On Sun, 27 Apr 2008, Knut Schwichtenberg wrote:

> thanks for your reply. I updated the file as you proposed - mostly. But there
> are at least three locations that need further discussion to make them 
> readable
> / understandable.
> Michael Hennebry wrote:
> > Page 4:

An error I'd forgotten:
simulavrxx -p5566, if otherwise correct should be simulavr -p5566.
For some reason, simulavrxx's executable is named simulavr.

Also "AVR-gdb" should be "avr-gdb".

> > From the "Attention:" paragraph, I gather that the example does not work.
> > It really should be replaced or supplemented by one that does.
> No, that is not meant. This is a general comment, meaning whenever you start
> simulavrxx with a command line "simulavrxx -g" it crashes. If you start it 
> with

The example begins "simulavr -g".
Does that work better?

> a command line "simulavrxx -g any_AVR_program" the simulator "survives". It
> starts simulating "any_AVR_program" until GDB loads the proper / wanted 
> program
> via GDB's file command.
> >
> > reason ... runs immediately with an empty flash.  But
> > ... fixed later.  It doesn't matter if you give the same
> > file on the command line and in the gdb file command.
> > At this point, I'm not sure how to fix it.
> > I'm not sure which command line is referenced.
> My proposal for the next release:
> It doesn't matter if the filename of the simulavrxx command line is identical 
> to
> the filename of GDB file command.
> The GDB downloads the file itself to the simulator.

I'd begin "It doesn't matter whether".
I'm not sure that "if" is wrong.
It's definitely common, but "whether",
having a narrower meaning, is easier
to read and is definitely correct and,

> > Page 8:
> > I had trouble with 5.1.3 up to MAX_INT.
> > The first sentence wasn't meaningful to me.
> :-)
> > I think that the next two sentences are intended to mean:
> > Digital Nets have potentially distinct input an output values
> > that represent a small number of digital states.
> > An AnalogNet has a "continuum" of values represented by
> > numbers in the range 0..MAX_INT.
> That's it. Shall I take your sentences or do you have any improvements?

Correct my tipo: "input and output values".

> > Is the upper bound MAX_INT or MAX_UINT?
> MAX_INT as far as I remember.
> >
> > The sentence with swig-I/F needs work, too, but it's getting close to noon.
> No need to hurry :-). It took so long time to get here...

I promised noon and made it with nearly a minute to spare.

> My proposal for the next release:
> The current implementation provides no network interface to register graphical
> components.
> Instead the swig-I/F is able to access any function of the simulator core.
> After your comment I'll finish the update and send a patch.

Michael   address@hidden
"Those parts of the system that you can hit with a hammer (not advised)
are called Hardware;  those program instructions that you can only
curse at are called Software."

reply via email to

[Prev in Thread] Current Thread [Next in Thread]