[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Slib-discuss] error with Gambit 4.9.3

From: Nick Gasson
Subject: Re: [Slib-discuss] error with Gambit 4.9.3
Date: Sun, 10 Jan 2021 17:35:15 +0800
User-agent: mu4e 1.4.13; emacs 27.1

On 01/10/21 10:35 am, Aubrey Jaffer wrote:
> I installed gambc (4.8.8-3.1) on Ubuntu and it starts successfully both
> with and without -:s.  However, with -:s, "./ gsi" accepts:
>   (define :: 5)
> but not without -:s.
> According to R5RS, :: is a valid identifier.
> Which version of Gambit are you running?  Perhaps there has been a
> recent change in its behavior. seems to be down
> tonight.

I got that error with 4.9.3 which is the latest release. I tried 4.8.8
and it works correctly with -:s as you say. I narrowed the problem down
to the define-macro at the end of gambit.init. This seems to be a bug in
Gambit 4.9.3, see here:

I tried the latest unreleased version and indeed it works correctly
again so I don't think there's any problem with SLIB here.

Thanks for your time.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]