[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Really, really dumb question - startup sequence for sendmail/spamass

From: Chuck Yerkes
Subject: Re: Really, really dumb question - startup sequence for sendmail/spamassassin/spamass-milter
Date: Thu, 6 Feb 2003 01:57:21 -0500
User-agent: Mutt/1.4i

I'm running in on a roaring Sparc 20 (150MHz, 128MB RAM),
so I start spamd as soon as possible (perl takes a little time).

I start the milter
I start the sendmail MTA (port 25, regular) "sendmail -L sm-mta -bd -q1h"
I run the "sendmail -L sm-msp-queue" one out of cron every 30 minutes
   (it just flushes the undelivered client queue ones).

The milter wants to be running before the main daemon starts.

Sendmail is paranoid about trust these days.  You get THIS:
> Feb  5 04:00:59 gate sm-mta[522]: h1590mvx000522: Milter (spamassassin): 
> local socket name /var/run/spamass.sock unsafe

Because something in that path is "untrusted".  Check ownership and perms:
  ls -ld  / /var /var/run /var/run/spamass.sock

Something is group or world writable or owned by an untrusted user.
(in fantasy land, the safefile() command would print the exact issue,
but for now it makes us all better admins by making us check).

Oh and adding "-u user" to your spamass-milter startup line
means you log the username.  (I wanna log either the message-ID
with each line or SOMETHING to let it be tracked with a certain
sendmail process).

Quoting Terry Kennedy (address@hidden):
>   I have a really dumb question. What is the recommended start sequence for
> sendmail (8.12.7, both the sendmail-mta and sendmail-queue daemons), spam-
> assassin (2.44, with spamd), and spamass-milter (0.1.3a) on a BSD/OS (should
> be similar to the other *BSD's) system?
>   I had this working in the past with the following in /etc/rc:
> /usr/sbin/sendmail -L sm-mta -bd -q30m
> /usr/sbin/sendmail -L sm-msp-queue -Ac -q30m
>   and then in /etc/rc.local doing:
> /usr/bin/spamd -d -u spamd
> /usr/local/bin/spamass-milter -f -p /var/run/spamass.sock
>   This was working until I upgraded all of the software (sendmail from 8.12.6
> to 8.12.7, spamassassin from 2.43 to 2.44, and spamass-milter from 1.2 to
> 1.3a). On a reboot, I got:
> Feb  5 03:58:34 gate sm-mta[248]: starting daemon (8.12.7): 
> address@hidden:30:00
> Feb  5 03:58:34 gate sm-msp-queue[251]: starting daemon (8.12.7): 
> address@hidden:30:00
> Feb  5 03:58:46 gate spamass-milter[322]: spamass-milter 0.1.3a starting
> Feb  5 03:58:48 gate spamd[320]: server started on port 783 (running version 
> 2.44)
> Feb  5 03:58:52 gate spamass-milter[322]: spamass-milter 0.1.3a exiting
> Feb  5 04:00:59 gate sm-mta[522]: h1590mvx000522: Milter (spamassassin): 
> local socket name /var/run/spamass.sock unsafe
> Feb  5 04:00:59 gate sm-mta[522]: h1590mvx000522: Milter (spamassassin): to 
> error state
>   and no spamass-milter process was running after this. I killed the 
> sendmails,
> started the milter, and re-started the sendmails and everything is Ok.
>   But that particular sequence (spamassassin/milter/sendmails) in the rc* 
> files
> generated other errors in the past, so I'm reluctant to try it "just to see
> what happens" now, since this is a production system.
>   I assume the complaint from sendmail is because the socket didn't exist
> when sendmail started, but why did spamass-milter exit? I assume that if
> the milter didn't exit, sendmail would have eventually noticed the socket
> appeared and things would have worked.
>         Terry Kennedy   
>         address@hidden             New York, NY USA
> _______________________________________________
> Spamass-milt-list mailing list
> address@hidden

reply via email to

[Prev in Thread] Current Thread [Next in Thread]