[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: -r option - FIXED

From: Jeff Powell
Subject: RE: -r option - FIXED
Date: Mon, 17 Mar 2003 18:09:14 -0800

I figured out what was wrong.  I had two copied of the spamass-milter
binary installed.  This probably occurred when I installed the RPM.  I
had one copy at /usr/local/sbin and another at /usr/sbin.  Apparently
the one at /usr/local/sbin came from installing the milter using make
install and the one at /usr/sbin came from installing the RPM.  I
modified the initscript and all is well.  It looks like the initscript
was reading the correct file but applying the options to the wrong copy
of the binary.

-----Original Message-----
From: Dan Nelson [mailto:address@hidden 
Sent: Monday, March 17, 2003 1:44 PM
To: Jeff Powell
Cc: address@hidden; address@hidden
Subject: Re: -r option

In the last episode (Mar 17), Jeff Powell said:
> On further inspection the milter does not appear to be applying ANY of

> the options in the /etc/sysconfig/spamass-milter file.  It is 
> definitely reading the file; I tried using Nigel Horne's -D option 
> (BEFORE adding the patch) and when I tried to restart spamass-milter 
> it complained (correctly) that -D was an invalid option.  I then 
> patched and reinstalled spamass-milter with the -D enabled.  This 
> time, it did not complain when I tried the -D option. So it appears to

> be reading the file, but not applying any of the options. The -D 
> option has no effect. The -d (debug) option has no effect. The -r 
> option has no effect.

After you start the service with the script, what is the output of "ps
ax | grep spamass-milter"?  You should see all your commandline args

Does it work if you run spamass-milter directly from the commandline? 

        Dan Nelson

reply via email to

[Prev in Thread] Current Thread [Next in Thread]