[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Speech-dispatcher on Fedora 9

From: Lars Bjørndal
Subject: Speech-dispatcher on Fedora 9
Date: Tue, 11 Nov 2008 16:07:29 +0100

Hi, Jan!
Jan Buchal <buchal at brailcom.org> writes:

>>>>>> "LB" == Lars Bj?rndal <lars.bjorndal at broadpark.no> writes:
>     LB> It seems to me that pulseaudio is, in Fedora, started somewhat
>     LB> automagically by GNOME, and it seems that it's under the user
>     LB> 'pulse'. Ok, so I started speech-dispatcher as the user pulse,
>     LB> and 'spd-say test', speaks. By the way, I get the following log
>     LB> output after spd-say:
>     >> I'm not an expert for pulseaudio but I think that the streategy
>     >> is, that pulse runs under user who is lodged. If pulseaudio runs
>     >> under pulse, I think that pulse works as system wide service. If
>     >> it is true then probably will be ok if you add an user to a pulse
>     >> group. pulse-access for example or something similar it depends
>     >> on you system.
>     LB> I've already added my regualr user lrs into the groups pulse,
>     LB> pulse-rt and pulse-access. After that, I started pulseaudio as
>     LB> user lrs, and I got error about couldn't connect to pulse.:
> You need start it then as root user probably, but that must say someone
> who use RedHat.

But then, I get the same error as if I start it as my regualr user.

>     LB> However, after starting SD as user pulse, I cannot use paplay
>     LB> any more:
>     >> And SD works with pulse output method?
>     LB> spd-say spoke, yes. But paplay stopped working.
> But the question is, if SD realy works with pulse audio output method or
> alsa.
Oh, sorry, I didn't understand. It worked with pulse audio output as
the user pulse. However, as said, paplay didn't work at the time
speech-dispatcher server was running.

>     LB> [root at lapx ~]# paplay /usr/share/sounds/warning.wav Connection
>     LB> failure: Access denied [root at lapx ~]#
>     >> 
>     LB> And no, I'm stucked...
>     >> 
>     >> >> Regarding a configuration of SD you can use system
>     >> configuration >> in /etc/speech-dispatcher or in
>     >> .speech-dispatcher in your home, >> in home of user under which
>     >> you runs SD. I recomment you try >> spd-conf script for easier
>     >> configuration of SD.
>     >> 
>     LB> That script seems to be missing in the Fedora distribution.
>     >> Hm, it seams that in Fedora is older version of SD. Which version
>     >> you have there?
>     LB> It's speech-dispatcher-0.6.6-18.
> I think that spd-conf is from 0.6.7 version.

Do you think I will get more success if upgrading SD?


reply via email to

[Prev in Thread] Current Thread [Next in Thread]