[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Synaptic-devel] "Please contact the author of this software if this

From: Philip Miller
Subject: Re: [Synaptic-devel] "Please contact the author of this software if this messageis diplayed"
Date: Wed, 14 Apr 2004 21:46:33 -0400
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040401 Debian/1.6-4

Thanks for CCing me, and please continue to do so, as I'm not subscribed.

Michael Vogt wrote:
On Tue, Apr 13, 2004 at 10:26:47PM -0400, Philip Miller wrote:

First off, "messageis" should be "message is". Patch would be attached, except grep can't find 'messageis' anywhere in the source. Neither is it to be found in the source of apt or dpkg.

Second, I've contacted you. What can I do to help debug this? I haven't tried to reproduce, because I've kept the "Applying Changes..." window of Synaptic open.

Thanks for contacting us. This message is displayed if there is a
unknown error condition returned from apt. I really want to know how
often this happens and under what cirumstances.

This is the first and only time I've seen the error. When I clicked close on that terminal and hit apply a second time, everything worked perfectly.

Did something got actually installed during the run that resulted in
this message?

Nothing got installed during that run. I copied the _complete_ text contents of that window below.

The complete contents of the window are as follows:

Please contact the author of this software if this messageis diplayed
y applied all changes. You can close the window now

I'm running Debian unstable ("Sid"). Presently, I use apt-watch and apt-listchanges. There may be some interaction among them causing this issue, and if there is, I'd be glad to help flush it out.

I've already filed a Debian bug on this matter, though the bug server seems to be running slowly, as I've not gotten the ACK with the bug number back yet.

Thanks. What kind of kernel do you run? How often did this happen? Is
it reproducable?

$ uname -a
Linux phil 2.6.5+phil1 #1 Sun Apr 4 14:16:16 EDT 2004 i686 GNU/Linux

Locally built, but no patches, just the vanilla source.

When I run it again from apt-watch, when it shows there are upgrades, I receive the same error on the first attempt at 'Apply'ing, and then it works correctly on the second, as before.

Philip miller

reply via email to

[Prev in Thread] Current Thread [Next in Thread]