[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Synaptic-devel] "Please contact the author of this software if this

From: Philip Miller
Subject: Re: [Synaptic-devel] "Please contact the author of this software if this messageis diplayed"
Date: Fri, 16 Apr 2004 17:33:39 -0400
User-agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6) Gecko/20040401 Debian/1.6-4

Michael Vogt wrote:
On Fri, Apr 16, 2004 at 03:57:38PM -0400, Philip Miller wrote:
Thanks. What kind of kernel do you run? How often did this happen? Is
it reproducable?

$ uname -a
Linux phil 2.6.5+phil1 #1 Sun Apr 4 14:16:16 EDT 2004 i686 GNU/Linux

Locally built, but no patches, just the vanilla source.

When I run it again from apt-watch, when it shows there are upgrades, I receive the same error on the first attempt at 'Apply'ing, and then it works correctly on the second, as before.

Thanks a lot. The apt-watch hint helped a lot. I can reproduce the
problem here and it looks like it's some issue with apt-watch and
libzvt (the library we use for terminal output). I have version of
synaptic that builds against a different terminal widget (vte from
latest cvs) and the problem does not occur then.

Out of curiosity, on Debian at least, why not just use the user's preferred xterm, rather than embeding your own? I would find synaptic much nicer if the output were in a gnome-terminal rather than the built-in one.

Does the version I put on work
for you?

Yes, it works flawlessly. Thank you for the quick turnaround.

Well, this  has technical reasons.  Synaptic embeds apt (libapt  to be
exact), it  does not exec it.  So we can  only use a terminal  that is
accessable from within gtk. I  would _love_ to use the terminal widget
that gnome-terminal uses  (that is vte). But the  current vte does not
have the support that synaptic needs (the cvs version has). Once a new
version of vte comes out we'll switch to it.

OK, cool. I can't wait.

Philip Miller

reply via email to

[Prev in Thread] Current Thread [Next in Thread]