[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Tinycc-devel] shared libraries broken..ish

From: Andrew Johnson
Subject: [Tinycc-devel] shared libraries broken..ish
Date: Tue, 26 Sep 2006 18:17:04 -0400 (EDT)

After patching tcc with the simple change for compound literals, I discovered 
that shared libraries don't work. Trying to use a shared library built in tcc, 
caused instant crashing. and gdb just gave a nice long list of ??.

Quite by accident, I discovered that after running strip on the resulting .so, 
it worked. I tried this with several other shared libraries, and it was the 
same in each one, all libraries are useless on build.. but after running strip 
on them, they appear to work fine.

Sometimes the actual binary grows on strip. Could it be that tcc is not 
properly building the structure for shared libraries, but close enough that 
strip fixes it?

I can deal for now, since strip "fixes" it for me, but if anyone has ideas, or 
a real fix I would appreciate it :)


reply via email to

[Prev in Thread] Current Thread [Next in Thread]