[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [Tinycc-devel] Error when compiling with tcc

From: Christian Jullien
Subject: Re: [Tinycc-devel] Error when compiling with tcc
Date: Wed, 15 Jan 2020 08:34:29 +0100

Hello Thiabaud,

The reported line does not exist on mod.

To help you, can you please tell us

-          If it still fails on mod

-          The system you use, I guess it’s Windows, right?


A snippet reproducing this bug will also help, I’ll try to run it on Windows x64 using mod.




From: Tinycc-devel [mailto:tinycc-devel-bounces+eligis=address@hidden] On Behalf Of Thiabaud Engelbrecht
Sent: Wednesday, January 15, 2020 04:51
To: address@hidden
Subject: [Tinycc-devel] Error when compiling with tcc


Hey all,


I've tried compiling a project with tcc. (It's fairly standard C99, and works with every other compiler I've tried, including GCC, clang, MSVC, MinGW, etc.)


When I attempt to compile, I get


tcc: x86_64-gen.c:421: load: Assertion `((ft & 0x000f) == 0) || ((ft & 0x000f) == 12) || ((ft & 0x000f) == 4) || ((ft & 0x000f) == 5) || ((ft & 0x000f) == 6)' failed.


I'm not sure exactly what this means, it seems to be something failing inside the compiler. Any insights would be appreciated.


I can provide more details/link to the project if anyone wants to have a look at it.




reply via email to

[Prev in Thread] Current Thread [Next in Thread]