[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (2.0.1); Can't save remote files.

From: Kai Großjohann
Subject: Re: tramp (2.0.1); Can't save remote files.
Date: Sat, 20 Jul 2002 12:16:18 +0200
User-agent: Gnus/5.090007 (Oort Gnus v0.07) Emacs/21.3.50 (i686-pc-linux-gnu)

Steve Youngs <address@hidden> writes:

> The subject pretty well says it all.  I tried to copy a file to a
> remote machine, and I got...
> "Not a tramp file name: /home/steve/upload/build-1.06-pkg.tar.gz"
> That was the local file.  The remote file was going to be:
> /[sm/address@hidden/build-1.06-pkg.tar.gz
> I also get the same error if I edit a remote file and then try to save
> it, but in that case Tramp complains about the "autosave" file not
> being a Tramp filename.
> I haven't looked too deeply into this yet, hopefully I'll get a chance
> late tonight or tomorrow night.

Oh, boy.  In the function tramp-do-copy-or-rename-file,
with-parsed-tramp-file-name is invoked for both the source and the
target files.  But with-parsed-tramp-file-name should never be called
on a non-Tramp file.

So the logic in that function should be rearranged.  If both files
are Tramp files, then the shortcut things can be tried.  If only one
file is a Tramp file, then we can either do the trick by invoking
rcp-program directly, or we go through a buffer.

[time passes]

I have now simplified the function a little bit by omitting the
special case where rcp was called directly.  I also changed the
function to account for the fact that with-parsed-tramp-file-name
barfs if the filename isn't a Tramp filename.

Does the new version work?  I haven't tested it.

A large number of young women don't trust men with beards.  (BFBS Radio)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]