[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (2.0.22); tramp errs: Remote `/bin/sh' didn't come up.

From: Kai Großjohann
Subject: Re: tramp (2.0.22); tramp errs: Remote `/bin/sh' didn't come up.
Date: Wed, 19 Feb 2003 20:43:58 +0100
User-agent: Gnus/5.090016 (Oort Gnus v0.16) Emacs/21.3.50

Martin Guertler <address@hidden> writes:

> What's your login shell on the remote machine? I ran into the same
> trouble when I tried to login to a machine where I have to have zsh as
> login shell. It has no PS1 env variable, the prompt there is
> named PROMPT1. As a kludge I changed
> tramp-shell-prompt-pattern. Maybe one could set more variables in
> the exec statement ..


The point of "exec env 'PS1=$ ' /bin/sh" is to change the prompt
produced by /bin/sh, not the prompt produced by your login shell.  So
unless your /bin/sh is a symlink to zsh, it won't help.

Or maybe you have configured which remote sh to use?  Bad Martin!  8-)
zsh does not appear to be sufficiently Bourne-ish, then.

But if you can convince me that it is useful for Tramp to use a zsh
instead of a Bourne shell on the remote host, then I could add
provisions to correct above exec statement.  (But I think it should
be possible to change the value of tramp-remote-sh in the
corresponding method definition to be "'PROMPT1=$ ' /usr/bin/zsh".)
A turnip curses Elvis

reply via email to

[Prev in Thread] Current Thread [Next in Thread]