[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Cygwin emacs, tramp, and kerberos

From: Charles Plager
Subject: Re: Cygwin emacs, tramp, and kerberos
Date: Fri, 16 May 2003 14:59:42 -0500
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3) Gecko/20030312

I think I solved my problem. Not only was I using kerberos to ssh/scp into various machines, I didn't have it configured correctly. I was telling kerberos to find the initializiation files using "c:\\cygwin\\bin\\krb5.conf", etc instead of "/bin/krb5.conf". I now seem to be able to read and write multiple files.
        Thanks for your help,
        Charles Plager
p.s. In case this happens to somebody else, one thing that I noticed is that I could ssh/scp from sone directories but not others when I had the environment variables formatted incorrectly. I'm still not exactly sure what happened, but it seems to be all better now.

Kai Großjohann wrote:
Charles Plager <address@hidden> writes:

When I try to edit a file on certain computers, the first file I load
works fine. When I try to load a second file, I get:

ssh_askpass: exec(/tmp/openssh/libexec/ssh-askpass): No such file or
Write failed: Cannot send after transport endpoint shutdown

Most interesting behavior.  I've never seen this before.  Please do
the following:

* start Emacs
* (setq tramp-debug-buffer t)
* (setq tramp-verbose 10)
* open a file
* put the contents of the *debug tramp/foo* buffer in a safe place
  or put a marker at the end or something
* open a second file
* get the new contents of the *debug tramp/foo* buffer that were
  added by opening the second file
* get the contents of the *tramp/foo* buffer

Send the *debug tramp/foo* buffer stuff, and indicate which part is
from open the first file and which part is from opening the second
file.  Also send the *tramp/foo* buffer.

When opening files, please try to avoid filename completion -- it
just clutters the *debug tramp/foo* buffer I guess.

Also, what method do you use?

Are the two files from the same host?

I hope we can squash that bug.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]