[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: efs + tramp + emacs problem.

From: Peter Valdemar Mørch
Subject: Re: efs + tramp + emacs problem.
Date: Sat, 03 Jan 2004 16:32:16 +0100
User-agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20031013 Thunderbird/0.3

Kai Grossjohann wrote:
Peter Valdemar Mørch <address@hidden> writes:

in *scratch* I tried
(find-file "/[ssh/address@hidden/etc/passwd")C-x C-e

  (find-file "/[ssh/address@hidden/etc/passwd")C-x C-e

What happens when you try the above?



Yes, the terminating ']' (that is "square-bracket-end") did the trick. I don't know, maybe MHonArc munged the terminating ']'. But it wasn't present in:
I just trusted the output.

(Oh, and maybe, just possibly maybe it was because I had forgotten to use my head!!)

Thanks a bundle! :-D


About the
(find-file "/ssh:address@hidden:/etc/passwd")
syntax in XEmacs:

(Tramp works for me now! That was the important thing. This syntax is just easier to remember... A nice-to-have..)

Michael seems to mention: "Solved meanwhile in CVS" and I'm not sure what it is that is solved. Do we agree whether (setq tramp-unified-filenames t) works in XEmacs? I can't get it to work.

I checked out the CVS version, and with this:
(require 'efs)
(add-to-list 'load-path "~/work/tramp/tramp/lisp/")
(add-to-list 'load-path "~/work/tramp/tramp/contrib/")
(add-to-list 'Info-default-directory-list "~/work/tramp/tramp/info/")
(setq tramp-unified-filenames t)
;; (require 'tramp)
;; or
(load-library "tramp")
(describe-variable 'tramp-version)
(find-file "/ssh:address@hidden:/etc/passwd")

describe variable did show the CVS version...

It still tries to "Opening FTP connection to ssh..."

- Peter

reply via email to

[Prev in Thread] Current Thread [Next in Thread]