[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Strange error -- Solved!

From: Michael Albinus
Subject: Re: Strange error -- Solved!
Date: Tue, 27 Apr 2004 17:48:32 +0200
User-agent: Gnus/5.1002 (Gnus v5.10.2) Emacs/20.7 (hpux)

Exaos Lee <address@hidden> writes:

> I found the reason:
> There is a file named "FreeMIDI:USB Installer Log" in the root
> directory / .
> When I use name completion after typing / , the tramp thought that the
> file "FreeMIDI:USE Installer Log" is a file from the host "FreeMIDI"
> and then try to open the host named "FreeMIDI" ....
> Is it a bug of tramp? When there is a file named sth. like
> "aa:bbb.ccc", can tramp recognize it as local file?

In fact, Tramp cannot load such a file if it is in the _root_
directory, because (expand-file "/aa:bbb.ccc") etc would be called
internally, which goes to Tramp via `file-name-handler-alist'.

I've tried other tricks like "/localhost:/aa:bbb.ccc" or
"/tmp/../aa:bbb.ccc" or "/./aa:bbb.ccc" - nothing works.

But I guess it is rather an Emacs problem. It should allow to mask the
":" character in file names, like it does for "$" (which is masked
with "$$").

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]