[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (2.1.0); scp method stopped working

From: Ted Stern
Subject: Re: tramp (2.1.0); scp method stopped working
Date: Tue, 18 May 2004 11:59:36 -0700
User-agent: Gnus/5.110003 (No Gnus v0.3) Emacs/21.3 (gnu/linux)

On 18 May 2004 at 10:08 PDT, Ted Stern wrote:
> On 17 May 2004 at 15:18 PDT, Ted Stern wrote:
>> I updated my anonCVS tramp checkout last friday, and a simple scp method edit
>> no longer works.  I updated again today, still no change.
>> The problem may be the new handling for ':' in filenames when called through
>> gnuserv.  I'm using the gnuserv-compat package with Emacs 21.3.
> Further debugging -- the error is in tramp.el.
> I'm attaching the diffs between the working and non-working versions.
> I tried changing the regexp for file matching (the first difference) back to
> the earlier version, but that did not fix the bug.  So one of the other diffs
> is the problem.
> I hope that helps localize things a bit ... to reproduce, try using the scp
> method to edit a shell script on a remote host with bash as the remote login
> shell.  Directory listings on the remote host work fine, the problem is
> actually loading the file.
> Ted

Even more specifically -- the problem is the change between tramp versions
2.360 and 2.361.  

| revision 2.361
| date: 2004/05/13 20:31:23;  author: albinus;  state: Exp;  lines: +12 -0
| * lisp/tramp.el (tramp-process-one-action)
| (tramp-process-one-multi-action, tramp-wait-for-regexp)
| (tramp-wait-for-output): Throw away if process has died. Reported
| by Luc Teirlinck <address@hidden>.

Michael, it looks like the tramp-wait-for-output function is overly sensitive.

 Ted Stern                                 Applications Group
 Cray Inc.                               office: 206-701-2182
 411 First Avenue South, Suite 600         cell: 206-383-1049
 Seattle, WA 98104-2860                     FAX: 206-701-2500

 Frango ut patefaciam -- I break that I may reveal
 (The Paleontological Society motto, equally apropos for debugging)

Index: tramp.el
RCS file: /cvsroot/tramp/tramp/lisp/tramp.el,v
retrieving revision 2.360
retrieving revision 2.361
diff -r2.360 -r2.361
>       (unless (memq (process-status p) '(run open))
>         (throw 'tramp-action 'process-died))
>       (unless (memq (process-status p) '(run open))
>         (throw 'tramp-action 'process-died))
>                (unless (memq (process-status proc) '(run open))
>                  (error "Process has died"))
>            (unless (memq (process-status proc) '(run open))
>              (error "Process has died"))
>                  (unless (memq (process-status proc) '(run open))
>                    (error "Process has died"))
>              (unless (memq (process-status proc) '(run open))
>                (error "Process has died"))

reply via email to

[Prev in Thread] Current Thread [Next in Thread]