[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (2.1.1); tramp hangs on 'Setting shell prompt'

From: Phil Suh
Subject: Re: tramp (2.1.1); tramp hangs on 'Setting shell prompt'
Date: Sat, 14 Aug 2004 10:04:54 -0700 (PDT)

On Sat, 14 Aug 2004, Michael Albinus wrote:

> Phil Suh <address@hidden> writes:
> > Using NTEmacs 21.3.1(Meadow2.1) and tramp 2.1.1,
> > Tramp is apparently hanging on 'Setting shell prompt'.
> > I've tried both sshx and plink, and it doesn't work either way.
> > I can access the remote box with ssh.exe(cygwin) and plink.exe(puTTY)
> > from cygwin and windows cmd line. But not via emacs/tramp.
> [...]
> > --- begin *debug tramp/foo*
> > # Opening connection for address@hidden using plink2...
> > # Waiting 60s for local shell to come up...
> > Microsoft Windows XP [Version 5.1.2600]
> > (C) Copyright 1985-2001 Microsoft Corp.
> >
> > c:\DOCUME~1\Phil\LOCALS~1\Temp># Sending command ` ; echo "Tramp connection 
> > closed"; sleep 1'

> Looks like your remote host is a Windows XP machine. This case, Tramp
> runs into problems, because it expects a Unix-like shell remotely. You
> see sending it commands, which are rejected by the Windows XP command
> executor.

I should clarify. My local machine is Windows XP. The remote host is
 a Unix box.  However, from the information in the tramp-debug-buffer I 
infer that Tramp is going to my local machine. I wondered if it
might be a DNS problem, but I tried the IP address of the remote Unix box
just now, with the same result. I also checked the logs of the remote Unix
box, and it never shows a connection from tramp.

Just now, trying a different unix box as a remote host had the same 
result. Bah.

I appreciate your reply, Michael.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]