[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Using ssh and/or tramp in xemacs

From: Kai Grossjohann
Subject: Re: Using ssh and/or tramp in xemacs
Date: Sun, 12 Dec 2004 14:51:59 +0100
User-agent: Gnus/5.110003 (No Gnus v0.3) Emacs/21.3.50 (gnu/linux)

Andrew DeFaria <address@hidden> writes:

> The contents of the *tramp* buffer:
> Pseudo-terminal will not be allocated because stdin is not a terminal.

This often happens when running Emacs on a Windows box.  It depends on
the ssh client in use.  There are two ways to work around it that I
know of.

One idea is to pass the "-t -t" options (yes, twice) to ssh.  There
are ready-made methods sshx and scpx that do this.  So there is some
chance that C-x C-f /sshx:address@hidden:/some/file RET (or, for XEmacs
users, C-x C-f /[sshx/address@hidden/some/file RET) might work out of the

Another idea is to invoke an interactive shell on the remote end.
This works by adding a tramp-methods entry that specifies, say, "bash
-i" for the tramp-remote-sh parameter.  For example, the fcp entry
does this.  (But you can't use that entry directly, I guess, because
you probably don't have fsh installed.)

Yet ANOTHER idea for Windows users is to install PuTTY and to use the
plink program included there.  I never tried, but presumably there was
at least one person for whom this worked.  There is a ready-made
"plink" method.

Kai (can't count)

reply via email to

[Prev in Thread] Current Thread [Next in Thread]