[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

tramp (2.1.2); Have not been able to use cygwin + emacs + tramp to conne

From: Spencer Thiel
Subject: tramp (2.1.2); Have not been able to use cygwin + emacs + tramp to connect.
Date: Sat, 15 Jan 2005 11:38:04 -0500

I have not had any luck connecting with tramp + emacs on WinXP.  If
you look below, you can see that the cmd.exe shell is trying to
intrepret commands that are intended for the remote shell.  I suspect
that the intial connection command (i.e. \c "ssh -t -t
address@hidden") is not getting sent to cmd.exe.  I have tried
switching to a local bash shell, but tramp is unable to connect to the
local shell.  This is tramp straight out of the box.  I have tried
using multiple methods.

When I use sshx (which is recommended for my setup), I get this
information in the tramp widow:
ssh -l foobar -e none -t -t /bin/sh; echo "Tramp"
"connection" "closed"; sleep 1
tcgetattr: Inappropriate ioctl for device

Any advice would be appreciated.

emacs-version's value is "21.3.1", tramp-version's value is "2.1.2"

# Opening connection for address@hidden using plink...
# Waiting 60s for local shell to come up...
Microsoft Windows XP [Version 5.1.2600]

(C) Copyright 1985-2001 Microsoft Corp.

c:\DOCUME~1\SPENCE~1\LOCALS~1\Temp># Sending command `plink -l cank  -ssh; echo "Tramp" "connection" "closed"; sleep
# Waiting for prompts from remote shell
# Waiting 60s for prompt from remote shell on host
# Looking for regexp "^.*\([pP]assword\|passphrase.*\):
Spencer Thiel
Boston University

reply via email to

[Prev in Thread] Current Thread [Next in Thread]