[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (2.1.7) slow

From: B52
Subject: Re: tramp (2.1.7) slow
Date: Wed, 27 Sep 2006 16:26:14 +0800

Thanks for the reminder...  scp works fine.  For curiosity, I also tried ssh with C-h v tramp-chunksize to take a peek of the variable after saving a remote file.  It's nil.  However, when I tried the test script in the tramp-chunksize doc, it hit a dead-loop at:

 (while (not (progn (goto-char (point-min))
                             (re-search-forward "\\w+" (point-max) t)))
            (accept-process-output proc 1))

Perhaps my Emacs is so incompatible with the ssh method so I guess I'll stick to scp.


On 9/27/06, Kai Grossjohann <address@hidden> wrote:
What's your value of tramp-chunksize?  (Use C-h v to find out; it may also be useful to read the documentation you find there.  You may need to switch to the *tramp/foo* buffer before hitting C-h v.)

Some connections to remote hosts are flaky, and Tramp circumvents the problem by sending stuff slowly.  If tramp-chunksize is not nil, then you have a flaky connection.

One possibility is to use an out-of-band method (like scp) to transfer the files.  Then the file transfer itself happens by invoking the program scp.  Here the slow-down does not happen.



B52 wrote:
Oops... sorry...  First, the wrong title as I was trying to be lazy and just replied on other's msg.  Second, it seems that tramp verbose level 5 tells the spot - it's at "Decoding region into remote file...".

I guess this is unavoidable... or is there some Emacs modules that I have missed which renders the slow process?

Many thks,

---------- Forwarded message ----------
From: B52 <address@hidden>
Date: Sep 27, 2006 4:02 AM
Subject: Re: tramp (2.1.7); ssh not default method
To: address@hidden

When saving remote files thru tramp ssh (2.1.7, running on Cygwin Emacs ), my PC CPU surges to near 100% with both in/out network traffic peaking also.  By setting verbose level to 8, it seems to be stuck at "Tramp: process-buffer nil", then "Tramp: check-remote-echo nil".  At level 10, it stays pretty static at "Tramp: process-buffer nil", then blinks a few times for "Tramp: *tramp/ssh address@hidden run".

Actually, what was tramp trying to do?

Many thks.

Tramp-devel mailing list

reply via email to

[Prev in Thread] Current Thread [Next in Thread]