[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: XEmacs segfault at startup w/ tramp 2.1.7

From: skip
Subject: Re: XEmacs segfault at startup w/ tramp 2.1.7
Date: Thu, 12 Oct 2006 22:18:40 -0500

    >> I downloaded tramp 2.1.7 to my Mac today.  When I start up XEmacs and
    >> the new tramp directory is in load-path I get a segmentaion
    >> violation.

    Michael> I haven't tried XEmacs+Tramp for a while, but there was a
    Michael> problem that XEmacs crashes when the Tramp files haven't been
    Michael> byte-compiled. Looks like it was because the coding system
    Michael> declared in the first line. IIRC I've reported that to the
    Michael> XEmacs mailing list, but there was no response. Maybe we shall
    Michael> reanimate this problem with XEmacs wizards.

    Michael> In short: try byte-compiled Tramp files.

Tried it, but I got the same result.  Then I renames the .el files to  That allowed XEmacs to get started.  However, trying to visit a
remote file fails with the error:

    Wrong number of arguments: tramp-find-method, 4

and this stack trace:

  # bind (standard-output stack-trace-on-signal debug-on-signal 
stack-trace-on-error debug-on-error)
  # (unwind-protect ...)
  tramp-find-method("rsync" nil "" "public_html/home/home.html")
  # bind (v filename)
  # bind (elt res handler-alist filename)
  # bind (completion filename)
  # (unwind-protect ...)
  # bind (match-data args operation)
  # bind (val insert completer initial-contents must-match default dir prompt 
  read-file-name-2(file-name-history "Find file: " nil nil nil nil 
  # bind (completer initial-contents must-match default dir prompt history type)
  read-file-name-1(file file-name-history "Find file: " nil nil nil nil 
  # bind (history initial-contents must-match default dir prompt)
  read-file-name("Find file: ")
  (list (read-file-name "Find file: ") (and current-prefix-arg 
(read-coding-system "Coding system: ")) t)
  # (condition-case ... . error)
  # (catch top-level ...)

I've just updated from 2.0.51 to 2.1.7.  I have these tramp settings in my
init.el file:

    (setq tramp-auto-save-directory auto-save-directory)
    (setq tramp-default-method "rsync")
    (defun ediff-file-remote-p (file-name)
      (car (cond ((featurep 'efs-auto) (efs-ftp-path file-name))
                 ((featurep 'tramp) (cons (tramp-tramp-file-p file-name) nil))
                 ((fboundp 'file-remote-p) (file-remote-p file-name)))))

I didn't see anything in the documentation about upgrading from earlier
versions.  Is there something else I need to do to make tramp 2.1.7 and
XEmacs play nice together?



reply via email to

[Prev in Thread] Current Thread [Next in Thread]