[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gdb over tramp

From: Michael Albinus
Subject: Re: gdb over tramp
Date: Wed, 28 Feb 2007 17:28:56 +0100
User-agent: Gnus/5.1008 (Gnus v5.10.8) Emacs/21.3 (hpux)

Ben Litton <address@hidden> writes:

> This gave me an idea. I ran gdb and this time told it to launch gdb
> --annotate=3 /ssh:devmachine:/opt/product/sbin/product. 
> gdb runs and successfully connects to the proper machine. I still get
> a "No such file or directory error," but at this point, if I load the
> file by hand 'file /opt/product/sbin/product' I can run the file. If I
> attempt to step through the file by pressing s in the *gud-product*
> buffer though, it steps through in the same way it would from the
> command line.

Yep. Tramp's hook into gdb is still kind of hackish, and the directory
must be either a full remote file name, or a relative file name
(including "../" navigation). In the latter case, the default
directory of the buffer you are starting gdb from is prepended.

I hope to polish it once the underlying primitives of remote process
handling have been extended in Emacs. But this is something for
after-the-release of Emacs 22.1.

> Thanks again,

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]