[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: gdb over tramp

From: Ben Litton
Subject: Re: gdb over tramp
Date: Wed, 28 Feb 2007 10:41:09 -0500

On Wed, 28 Feb 2007 07:32:04 +0100
Michael Albinus <address@hidden> wrote:

> I've shortly tested it, everything looks OK to me. gdb runs on the
> remote machine.
> Could you, please, give a short scenario how you apply gdb?

I'm working on source code on a remote machine with multiple make
targets. While having one of the source files open and with focus in
that window, I hit M-x gdb and choose the install path
gdb --annotate=3 /opt/product/sbin/product for it to execute. It opens
up gdb and in that buffer it says 

Current directory is /opt/product/sbin/
No such file or directory.

> What is the first line in your *gud-emacs* buffer? I have the
> following one, which tells me that gdb is running on the remote host:
> Current directory is /ssh:address@hidden:/home/albinus/src/emacs/src/

This gave me an idea. I ran gdb and this time told it to launch gdb
--annotate=3 /ssh:devmachine:/opt/product/sbin/product. 

gdb runs and successfully connects to the proper machine. I still get
a "No such file or directory error," but at this point, if I load the
file by hand 'file /opt/product/sbin/product' I can run the file. If I
attempt to step through the file by pressing s in the *gud-product*
buffer though, it steps through in the same way it would from the
command line.

> Best regards, Michael.

Thanks again,

Ben Litton

reply via email to

[Prev in Thread] Current Thread [Next in Thread]