[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Problem compiling remote files

From: Ulf Stegemann
Subject: Re: Problem compiling remote files
Date: Mon, 09 Mar 2009 09:35:51 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.0.91 (gnu/linux)


Michael Albinus <address@hidden> wrote:

> Ulf Stegemann <address@hidden> writes:
>> this is tramp 2.1.15 with emacs (CVS as of yesterday) on
>> linux.
> I run Emacs 23.0.90 and Tramp 2.1.16-pre. Closed to your versions.
>> I have problems compiling remote files with M-x compile. Although
>> compilation works, emacs does never notice that it's finished, which
>> results in status `run' in the modeline and a warning when compiling
>> again.
> I have tried it; no problem. Compilation exits as expected, modeline
> changes.
> Could you, please, send the contents of the compilation buffer? Tramp
> debug buffer might be helpful as well.

I was able to narrow down this a little bit. The problem occurs only
when trying to compile a file opened by multihop, in my case su via ssh.
When accessing the file directly, compile behaves as expected (I tried
ssh and scpc methods).

Anyway, you've asked for the compilation and debug buffers. The
compilation is started with an ordinary `make' and is about to create
the binary data file for tinydns (something that should be done as
root). The output of the compilation buffer follows, the slightly
shortened debug buffer is attached.


-*- mode: compilation; default-directory: 
"/su:address@hidden:/etc/tinydns/root/" -*-
Compilation started at Mon Mar  9 06:03:59

Tramp connection closed



Attachment: tramp-debug.txt
Description: Text document

reply via email to

[Prev in Thread] Current Thread [Next in Thread]