[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Wrong type argument: eventp, nil

From: skip
Subject: Wrong type argument: eventp, nil
Date: Wed, 23 Dec 2009 11:11:23 -0600

It's been ages since I tried to figure out problems with (X|GNU)Emacs
and tramp, but I find myself in that situation now with a problem I
don't know how to approach.  If I execute this command:

    xemacs -vanilla '/[scp/tuba]/etc/hosts'

XEmacs opens but then complains:

    Wrong type argument: eventp, nil

If I then visit the same remote file it succeeds (though it erroneously
marks the /etc/hosts buffer modified).

I added -eval '(setq stack-trace-on-error)' to the command line and
tried again.  Here is the stack trace:

      # bind (standard-output stack-trace-on-signal debug-on-signal
      # stack-trace-on-error debug-on-error)
      # (unwind-protect ...)
      signal(wrong-type-argument (eventp nil))
      # bind (data error-symbol)
      signal-error(wrong-type-argument (eventp nil))
      # bind (error-data)
      # (condition-case ... . error)
      # (catch top-level ...)

I get the same result when running with -nw.  I am using Tramp v. 2.0.55
in XEmacs 21.5.28 on Solaris.  According to the XEmacs package manager I
have 1.37 installed but the latest version available from XEmacs is
1.16.  From looking at the downloads area it seems that 2.1.17 is the
latest version.  Given that 2.0.55 is so old should I simply upgrade?
Any idea what the stack trace is about?  It doesn't actually mention


Skip Montanaro - address@hidden -

reply via email to

[Prev in Thread] Current Thread [Next in Thread]