[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Curious permission problem

From: Michael Albinus
Subject: Re: Curious permission problem
Date: Wed, 17 Feb 2010 12:18:27 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/23.1.92 (gnu/linux)

Ole Laursen <address@hidden> writes:

> Actually, I just tried opening one of the remote file with Emacs
> running as root. Now I can read the file, but I can't write to it. So
> actually, I think setting read permissions only is not necessarily
> enough?

I could reproduce the problem. However, it is different from the
previous one. When you save a file, `set-file-modes' is called by
`basic-save-buffer'. This is needed in order to keep permissions, when
the original file version has been moved to be the backup file.

This operation fails, when you are not the owner of the file. It is the
same for local files: Try to open a local file, owned by root, with
permissions "---xrwxr--". Modify it, and save it.

Maybe modifying `backup-by-copying' helps; I haven't tried.

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]