[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: default remote shell in tramp

From: Terrence Brannon
Subject: Re: default remote shell in tramp
Date: Mon, 28 Jun 2010 10:57:00 -0400

On Mon, Jun 28, 2010 at 10:55 AM, Terrence Brannon <address@hidden> wrote:

On Thu, Jun 17, 2010 at 3:27 PM, Michael Albinus <address@hidden> wrote:
Vinh Nguyen <address@hidden> writes:

> I tried this before and I just tried it again.  Issue is the commands
> I'm looking for is in PATH that is defined in my .bashrc file on the
> remote machines.  Hence, I think the error is coming from the fact
> that /bin/sh is used (as the error states).
> I think the solution is to have tramp use bash on my remote machine.
> Does this make sense?

Yes. You could change the used remote shell in `tramp-methods' to
bash. If you, for example, use "ssh", you could apply

(setcdr (assoc 'tramp-remote-sh (assoc "ssh" tramp-methods)) '("/bin/bash"))

For some reason, that is not doing anything:
but it doesnt matter on the Linux system I'm using because "sh" is symlinked to "bash"

reply via email to

[Prev in Thread] Current Thread [Next in Thread]