[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: TRAMP hanging on “Waiting for prompts …”

From: Michael Albinus
Subject: Re: TRAMP hanging on “Waiting for prompts …”
Date: Mon, 26 Sep 2011 12:21:32 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.0.50 (gnu/linux)

Sean Whitton <address@hidden> writes:

> Dear all,


> Been happily using TRAMP for months but all of a sudden it’s hanging on
> “Waiting for prompts from remote server”.  Have tried on a different
> machine with identical Emacs config and it works fine, so I think there
> might be a cache file that’s corrupted that I need to remove, or
> something?  I’ve tried deleting ~/.emacs.d/tramp but that doesn’t help.

You must stop Emacs, delete ~/.emacs.d/tramp, and restart Emacs then.
~/.emacs.d/tramp is written when exiting Emacs.

Much simpler is to call "M-x tramp-cleanup-all-connections", which has
the same effect.

> 10:37:03.026874 tramp-send-command (6) # exec ssh -l swhitton  -e none athena


> 10:37:04.032096 tramp-accept-process-output (10) # *tramp/ssh address@hidden 
> run
> 10:37:04.904014 tramp-accept-process-output (3) # Opening connection for 
> address@hidden using ssh...done
> 10:37:04.904150 tramp-file-name-handler (1) # Interrupt received in operation 
> (expand-file-name /athena:htdocs/blog/entries/ nil)

This is less than 2 seconds. Have you interrupted the connection

According to the traces, the remote server didn't return any string
(yet). What happens, if you call in a shell

# ssh -l swhitton  -e none athena

> Thanks.
> S

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]