[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: TRAMP hanging on "Waiting for prompts"

From: Michael Albinus
Subject: Re: TRAMP hanging on "Waiting for prompts"
Date: Fri, 30 Sep 2011 13:06:21 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/24.0.50 (gnu/linux)

Sean Whitton <address@hidden> writes:

> Dear Michael,

Hi Sean,

> Something just occurred to me and I tried it out, and I am hoping it
> sheds some light.
> Firstly, I tried using some alternative TRAMP methods: FTP and sudo.
> Neither work on an emacs -Q.
> Then I thought: maybe this is something to do with my system account.
> So I ran sudo emacs -Q, and from there everything worked again.  I
> copied the SSH key for athena to /root and even that worked.
> Have you ever seen something like this before where a non-root user
> couldn’t use TRAMP but root could?

I don't believe this is because of root permissions. Rather a
configuration issue.

Move your .profile and friends away. Move all of your files in .ssh/
away, except the key file. Check permissions in /tmp. Log out. Log
in. Try it again, with "emacs -Q".

If that works, you can start to bring back the moved files, one after
the other. By this, you could find out what's the problem.

> I have new hope.
> S

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]