[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (2.2.6-24.3); connecting through socks and ssh hangs without p

From: Dennis van Dok
Subject: Re: tramp (2.2.6-24.3); connecting through socks and ssh hangs without prompt
Date: Wed, 17 Dec 2014 11:47:41 +0100
User-agent: Mozilla/5.0 (X11; Linux x86_64; rv:31.0) Gecko/20100101 Icedove/31.2.0

On 16-12-14 21:01, Michael Albinus wrote:
> Dennis van Dok <address@hidden> writes:
>> Hi,
> Hi Dennis,
>> thanks for looking into this. I tried building tramp from git master and
>> running with my emacs 24.3.1, by typing 'Mx load-library tramp' but I
>> got a strange error
>> 'Autoloading failed to define function socks-original-open-network-stream'.
> Did you adapt load-path accordongly?

Yes, I did a 'make install' in ~/share/emacs/lisp, which was already in my load 
>> Don't know what to do now. :-(
> I have installed Emacs 24.3 from Ubuntu 14.10. No problem with that:
> # emacs24 -Q -L ~/src/tramp/lisp '/socks:localhost#2020|ssh:myhost:'

This fails with the same error. Maybe the problem is in the build;
I had to resort to --with-contrib or I  get:

./configure --with-lispdir=/home/user/share/emacs/lisp 
configure: Tramp 2.2.11-pre
checking for gmake... no
checking for make... make
checking for reasonable make version... ok
checking whether make sets $(MAKE)... yes
checking for emacs... yes
checking for emacs flavor... emacs
checking for emacs gvfs support... yes
checking for emacs gateway support... yes
checking for emacs version... ok
checking for base64.el... ok
checking for format-spec.el... not found
configure: error: Use --with-contrib for implementation supplied with Tramp

The missing function is in socks.el, which is in the correct path.

When I issue a 'M-x load-library' 'socks.el' I get a step further, but now it 

Tramp: Opening connection for using ssh...failed

With traces:

11:46:07.467684 tramp-get-connection-property (7) # ~ undef
11:46:07.467871 tramp-get-connection-property (7) # process-name nil
11:46:07.467994 tramp-get-connection-property (7) # process-name nil
11:46:07.468099 tramp-get-connection-property (7) # process-buffer nil
11:46:07.468405 tramp-maybe-open-connection (3) # Opening connection for using ssh...
11:46:07.468789 tramp-compute-multi-hops (5) # Add proxy ("bleek\.nikhef\.nl" 
"nil" "/socks:localhost#2020:")
11:46:07.470634 tramp-gw-open-connection (3) # Opening connection for using ssh...failed



reply via email to

[Prev in Thread] Current Thread [Next in Thread]