[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tramp loads files but gets stuck always until C-g pressed.....with e

From: Christian Seberino
Subject: Re: Tramp loads files but gets stuck always until C-g pressed.....with every shell tried and prompt
Date: Sun, 25 Jan 2015 15:47:32 -0600

Thanks for the reply.....Is Tramp implemented with hg (mercurial)?  As it happens my remote code is in a Mercurial repository but I had this bug when I tried to simply open the file..... So I'm confused how mercurial entered into it

On Jan 25, 2015 2:59 PM, "Michael Albinus" <address@hidden> wrote:
Christian Seberino <address@hidden> writes:

> Tramp debug output...

... and here we are:

> 12:04:00.450327 tramp-send-command (6) # ( \cd
> /home/cs/Ws/philfour/mvc/views/; hg log -l 1 --template \{rev\}
> about.html </dev/null; echo tramp_exit_status $? )

That's what Tramp sends to the remote host, in order to get hg
information about the file about.html.

> 12:04:00.553760 tramp-accept-process-output (10) #
> WARNING: terminal is not fully functional
> -  (press RETURN)

And that's what the hg process returns. It is not happy with the
terminal settings and wants the interactive user to enter RET. Tramp,
obviously, does not understand.

The most simple workaround would be to suppress hg checks. Do you need
them? If not, kick them out.

If you want to get hg information about remote files, I'm a little bit
out of knowledge. Likely, hg needs some settings for that I'm not aware

I remember a similar bug with hg where it was sufficient to set the
HGPLAIN environment variable. Don't know whether it applies here also.

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]