[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

How do I debug this?

From: Mark Geary
Subject: How do I debug this?
Date: Wed, 23 Aug 2017 13:18:00 -0400 (EDT)
User-agent: Alpine 2.21 (BSF 202 2017-01-01)

I'm on a Mac running MacOS 10.9, and emacs 25.2.1 and whatever Tramp
comes with that. I'm trying to open a file on a remote machine running
FreeBSD 11.1-STABLE using:

    C-x C-f /

This worked just fine before I went on vacation a
few weeks ago. While I was gone the admin of the remote made these

    This server has been updated with new software installed on
    Aug 08 2017.

    Upon upgrade to FreeBSD 11.1 the SSL and SSH daemons have changed
    their default encryption types.

    This may require a change of keys upon connection to the upgraded server.

Now when I try to open a remote file, Tramp sits and spins with
"Waiting for prompts from remote shell...". When it times out, the
*tramp/ssh* buffer is empty.

However using ssh to connect from the command line works just fine.

My first thought was that this problem results from the SSH changes,
but I suppose it might be something else.

I've tried setting (custom-set-variables '(tramp-verbose 6)), but the
contents of the debug directory are rather opaque to me. I can see
that Tramp is doing lots of regex matching, but it's not obvious to me
what text from the remote machine it's trying to macth against, or
what most of the particular regexp purposes are.

How do I start to debug this?

Mark Geary

Fifty-four Forty or Fight!

reply via email to

[Prev in Thread] Current Thread [Next in Thread]