[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tramp on Windows connects to Linux but not to OSX

From: Michael Albinus
Subject: Re: Tramp on Windows connects to Linux but not to OSX
Date: Tue, 13 Mar 2018 16:42:51 +0100
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/26.0.91 (gnu/linux)

Schönes Wetter Schönes Gefühl <address@hidden> writes:


> I've tried adding the recommended lines to ~/.profile but there's no
> change in situation. Anyway, that same problem happens in another Mac
> mini computer on which no iTerm2  installed, i.e. the problem must be
> related to the core OSX.

Finally, I've found the time to check your traces, again. In
the last sent command is

12:10:09.591093 tramp-send-command (6) # set +o vi +o emacs

And it returns

12:10:09.645096 tramp-accept-process-output (10) # *tramp/plink address@hidden 
run *tramp/plink address@hidden

which is the expected prompt twice. Well, this might be due to the
previous command

12:10:09.535090 tramp-send-command (6) # echo foo ; echo bar

Double-prompt problem, which I thought it wass solved for a long time. Hmm.

Could you try the following patch? It is created on the development
version of tramp-sh.el, line numbers might vary.

--8<---------------cut here---------------start------------->8---
diff --git a/lisp/tramp-sh.el b/lisp/tramp-sh.el
index f619ac30..0cdf42de 100644
--- a/lisp/tramp-sh.el
+++ b/lisp/tramp-sh.el
@@ -4175,7 +4175,7 @@ process to set up.  VEC specifies the connection."
               cs-encode (if (string-match "^Darwin" uname) 'mac 'unix)))
-       (tramp-send-command vec "echo foo ; echo bar" t)
+       (tramp-send-command vec "(echo foo ; echo bar)" t)
        (goto-char (point-min))
        (when (search-forward "\r" nil t)
          (setq cs-decode (coding-system-change-eol-conversion cs-decode 'dos)))
--8<---------------cut here---------------end--------------->8---

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]