[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: The “//” fix confuses cygwin-mount

From: Michael Albinus
Subject: Re: The “//” fix confuses cygwin-mount
Date: Fri, 28 Sep 2018 18:01:17 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/27.0.50 (gnu/linux)

Andy Moreton <address@hidden> writes:

Hi Andy,

> On Fri 28 Sep 2018, Michael Albinus wrote:
>> On an MS Windows machine, I have installed
>> GNU Emacs 26.1 (build 1, x86_64-unknown-cygwin)
>>  of 2018-05-28
>> (That's the version distributed by Cygwin.). And I have also installed
>> recent Tramp
>> tramp-version
>> => "2.4.1-pre"
>> When I run your example, I get
>> (substitute-in-file-name "/method:host:/foo")
>> => "/method:host:/foo"
>> Everything looks normal. What do I miss?
> Here you are running a cygwin build of emacs, but the problem occurs
> when running a native Windows version of emacs (Mingw,org or MSYS2).

The most recent Emacs 27 for MS Windows I could find is located at
<>. It refers
itself as

"GNU Emacs 27.0.50 (build 1, x86_64-w64-mingw32)
 of 2018-05-04"

This version works also as expected

(substitute-in-file-name "/method:host:/foo")

> cygwin-mount.el allows a native Windows emacs to understand the mapping
> between POSIX paths used in cgywin and the equivalent Windows native
> paths (found by parsing the output from the Cygwin 'mount' executable).

I don't know cygwin-mount.el. On the marmalade repo, I found it in
version "2001". Installed and evall'ed locally, and rerun the test

(substitute-in-file-name "/method:host:/foo")

Still the same correct behavior. Have you tried to start your Emacs with
the -Q argument, and then load cygwin-mount.el alone? Still the same problem?

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]