[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (; cannot connect to SimpleSSHD on Android

From: Francesco Potortì
Subject: Re: tramp (; cannot connect to SimpleSSHD on Android
Date: Thu, 11 Apr 2019 14:11:23 +0200

>> I try to connect to a SimpleSSHD server running on Android.  Tramp does
>> something, then asks me for a passphrase, then it thinks a while, asks
>> me for a second passphrase and so on.
>> The SimpleSSHD server logs:
>>   Child connection from [ipv6 address]
>> then, two seconds later:
>>   Exit before auth
>Hmm, there's a problem with D-Bus:
>> 12:09:02.162156 tramp-gvfs-handler-askpassword (6) # "Enter passphrase for 
>> secure key for" "" "" 9
>> 12:09:07.183690 tramp-gvfs-dbus-event-error (1) # File error: Password 
>> dialog cancelled
>Hard to debug. Does it help to use ssh or scp instead of sftp?

Cannot use ssh or scp on that server, as it has no /bin/sh (maybe it is
possible to install one, I do not know).  So I tried sftp to see if that
could work, since I can access the Android server with sftp from the
command line and also using the Gnome/Mate remote server access, which I
suppose uses sftp (they call it SSH method).

>Does sftp work in general, or is it broken also for other hosts (no
>Android devices)?

Just tried (never used it before) and no, it does not work, same
behaviour.  Note that starting with Gpg2 (if I remember correctly) which
used a keyring daemon under X to get the password propmpt, I regularly
kill the keyring daemon, in order to get the password prompt in the
Emacs minibuffer.  That works with gpg mail.  I suspect that Tramp does
something that needs the keyring daemon whe using sftp:.  I use
regularly ssh: or scp: and they work.

Ah, using ssh: on that server works until it tries to execute /bin/sh,
meaning the login does in fact work

reply via email to

[Prev in Thread] Current Thread [Next in Thread]