[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Tramp is operating on host filesystem instead of container filesyste

From: Camden Narzt
Subject: Re: Tramp is operating on host filesystem instead of container filesystem
Date: Wed, 13 May 2020 09:38:43 -0600

So I started the docker container, and checked it with docker ps, that worked.
I started a fresh emacs with /usr/local/bin/emacs -Q,  and it had obviously not loaded my usual emacs config, so that worked.
I pasted the load library and setq lines into the scratch buffer in the clean emacs and evaluated it (messages buffer confirmed it loaded ok).

For information about GNU Emacs and the GNU system, type C-h C-a.
Mark set
Mark set [3 times]
Loading /Users/camdennarzt/.emacs.d/elpa/docker-tramp-20170207.325/docker-tramp-autoloads.el (source)...done
t [2 times]
Quit [2 times]
Mark set [2 times]

However at that point when I do C-x C-f /doc <TAB> nothing is completed.

If I type out /docker: completely then the rest of the steps work as expected.

So what works from a clean emacs is the inverse of what works with my normal config.


On May 13, 2020, at 9:23 AM, Michael Albinus <address@hidden> wrote:

Camden Narzt <address@hidden> writes:

Hi Camden,

Using the docker-tramp package from Melpa (installed via
package-list-packages) the file path portion of the completion still
shows the files on the host filesystem, and opens files on the host OS
when I write a path manually.

I have started "docker run -it --name alpine --rm alpine:latest sh", my
usual test case. Then I've started Emacs 26.3 via "emacs -Q".

In Emacs, I have loaded the docker-tramp package via

--8<---------------cut here---------------start------------->8---
(load-library "~/.emacs.d/elpa/docker-tramp-20170207.325/docker-tramp-autoloads.el")
(setq docker-tramp-use-names t)
--8<---------------cut here---------------end--------------->8---

Now I can do

--8<---------------cut here---------------start------------->8---
C-x C-f /doc <TAB>
=> /docker:

alp <TAB>
=> /docker:alpine:

=> /docker:alpine:.
=> Possible completions are:
--8<---------------cut here---------------end--------------->8---

All of this looks OK to me. Could you pls check, whether this works also
for you?

Best regards, Michael.

reply via email to

[Prev in Thread] Current Thread [Next in Thread]