[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp (2.5.0-pre master/10a0941f4dcc85d95279ae67032ec04463a44d59); C

From: Jean Louis
Subject: Re: tramp (2.5.0-pre master/10a0941f4dcc85d95279ae67032ec04463a44d59); Couldn't find proper ls command
Date: Thu, 9 Jul 2020 11:29:35 +0300
User-agent: Mutt/1.14.0 (2020-05-02)

* Michael Albinus <> [2020-07-08 19:51]:
> Jean Louis <> writes:
> Hi,
> > What I can see is that shell-file-name is "/bin/sh" but it is
> > incorrect, and I did not change my previous settings, Tramp was
> > working just fine. Suddenly it does not work on any Android device.
> >
> > local variables:
> > ================
> > ;; *tramp/scp motorola*
> > (setq-local
> >  connection-local-variables-alist '((shell-command-switch . "-c") 
> > (shell-file-name . "/bin/sh"))
> >  default-directory "/scp:motorola:"
> >  )
> This is the problem. You connect an Android device, which has the shell
> somewhere else. Please read the Tramp manual how to set a connection
> local variable; I guess you need "/system/bin/sh" as
> `shell-file-name`.

Thank you and sorry for taking your time. I did set the
tramp-remote-path correctly and it worked quite well for days. It was
permanent settings. Suddenly this error that `ls' cannot be found
started appearing and I could not connect to any device
anymore. Because I already solved all issues, it was no resolution and
I filed bug.

Then yesterday I also noticed that shell-file-name is /bin/sh and I
verified tramp-remote-path and I did not see the path that should be
there: "/data/data/com.termux/files/usr/bin/" so I added it again, and
now it works.


reply via email to

[Prev in Thread] Current Thread [Next in Thread]