[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: sshx protocol from MS Windows occasionally cuts off results in M-x r

From: Jim Porter
Subject: Re: sshx protocol from MS Windows occasionally cuts off results in M-x rgrep
Date: Wed, 5 May 2021 22:13:06 -0700

On Wed, May 5, 2021 at 9:35 AM Michael Albinus <> wrote:
> Jim Porter <> writes:
> > If I run these manually in cmd.exe, the command prompt closes
> > immediately. If I'm understanding things correctly, I think that's
> > because of the `exit' in the first command and the `exec' in the
> > second. If I open a subshell (by running cmd.exe in an existing
> > command prompt), the window stays open and I can see the output. I've
> > tried a bunch of times, but I'm completely unable to reproduce the
> > issue when running in cmd.exe. That suggests to me that the MS Windows
> > ssh client is working ok, or at least that any bugs here can be
> > avoided if we're careful.
> I've tried all these tests (manual invocation of ssh etc pp) already
> yesterday, with the same result as you. It works.
> Interestingly, there's no such problem when using plink, which uses the
> same command sequence. That lets me think it is an ssh client problem,
> buffering the output or whatever. But I might be wrong.

Indeed, it's hard to say for sure what's going wrong, since I still
haven't been able to isolate the bug. I did make a bit of progress
though. First, I eliminated the need to use `M-x rgrep' on the Tramp
repository. The attached Python script (which just prints the text
copied from the previous `M-x rgrep' output one line at a time) also
reproduces the issue fairly reliably if invoked via `M-x compile RET
python3 RET' over sshx from MS Windows.

However, I *don't* see this issue when I run `M-x shell-command RET
python3 RET'. I always see the full output. This makes me
wonder if the issue is actually in `M-x compile'. I'm not
super-familiar with all the differences between how `shell-command'
and `compile' invoke a process, but maybe there's some sort of issue
with buffering in `compile.el' that's causing this?

I'll keep debugging this to see if I can narrow this down further.

- Jim

Description: Text Data

reply via email to

[Prev in Thread] Current Thread [Next in Thread]