[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: tramp ( nil/nil); emacs-28.0.50: Can't copy a 1.4 MB file wit

From: H. Dieter Wilhelm
Subject: Re: tramp ( nil/nil); emacs-28.0.50: Can't copy a 1.4 MB file with the plinkx method
Date: Sat, 23 Oct 2021 21:34:07 +0200
User-agent: Gnus/5.13 (Gnus v5.13) Emacs/28.0.60 (gnu/linux)

Michael Albinus <> writes:

Hi Michael

>> But when it is an openssh implementation why do you need to distinct ssh
>> and sshx?  Doesn't the MS version know to use ~/.ssh/config?
> sshx (and scpx) establish pseudo terminals, needed on MS Windows. See
> the "-t -t" arguments of the ssh call.

I see, thanks

> There is `large-file-warning-threshold', which you could set to
> nil. This is a global variable (not Tramp specific); don't know whether
> it is needed to make it configurable just for Tramp.

Oh, I thought the y-or-no-p is coming from Tramp itself.

> However, copying a bunch of large files, I believe Tramp's scp is
> preferable. This doesn't ask this question (I hope :-)

I checked /scp on Linux but for the first start it it didn't give me the
accustomed dired "layout", it looked more like a directory listing with
C-x C-d!  (Maybe I even did C-x C-d.) Anyway when I tried it a second
time it looked like dired.

And /scp didn't query me, thank you. :-)

Could I run such a lengthy copying process asynchronously with:

     (add-to-list 'tramp-connection-properties
                  (list (regexp-quote "/scp:user@host:")
                        "direct-async-process" t))


Best wishes
H. Dieter Wilhelm
Zwingenberg, Germany

reply via email to

[Prev in Thread] Current Thread [Next in Thread]