viewmail-info
[Top][All Lists]
Advanced

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [VM] IMAP protocol error on save after get


From: Robert Marshall
Subject: Re: [VM] IMAP protocol error on save after get
Date: Fri, 7 Nov 2014 20:35:30 +0000

Uday

I've just installed 24.4 and - so far (based upon running it most of
today) - I've not seen the problem. So it looks to be a trunk vs
release difference. Both the trunk and the release were run from the
build areas.

When the problem occurred (with the trunk version) I was also seeing
an occasional

Error running timer `vm-check-mail-itimer-function': (vm-imap-protocol-error 
"No response from the IMAP server")

message in the echo area - I use vm-mail-check-interval, and sometimes
I had to attempt to exit the imap folder twice as the first time it
errored

You think a report to emacs-bug?

I see this

2014-07-07  Paul Eggert  <address@hidden>

        Minor fixups related to usage of the 'long' type.
        * gnutls.c (emacs_gnutls_handshake):

but that seems to be the only tls related checkin since the last
one in the release -  or does imap use other bits of core emacs?

I'm using imap-ssl:host:993:*:login:user:* for the
vm-imap-account-alist connection

Robert

Uday Reddy writes:
 > Dear Robert, Is this problem still happening with Emacs 24.4?
 > 
 > Cheers,
 > Uday
 > 
 > Robert Marshall writes:
 > 
 > > I'm running with a recent build from the emacs devel trunk and since
 > > I've swapped to this version I'm consistently seeing this error:
 > > 
 > > vm-imap-protocol-error: IMAP protocol error: "No response from the IMAP 
 > > server"
 > > 
 > > this happens (with an imap folder) if I do a get ('g') followed
 > > immediately by a save ('S'). If I then save again it works, so it's a
 > > minor inconvenience rather than a real problem. Is there something
 > > fragile in folder saving that's likely to be generating this error or is
 > > it more likely to be an core emacs issue? They are in the midst of the
 > > latest pretest which will hopefully be the last before the next release:
 > > has anyone built from that who is also seeing this error?
 > > 
 > > I haven't seen this problem at all before my move to this emacs build.
 > > 
 > > Robert
 > > -- 
 > > La grenouille songe..dans son ch√Ęteau d'eau
 > > Links and things http://rmstar.blogspot.com/
 > 



reply via email to

[Prev in Thread] Current Thread [Next in Thread]