[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [vile] How to use map! to enter 'special' UTF8 characters?

From: Chris Green
Subject: Re: [vile] How to use map! to enter 'special' UTF8 characters?
Date: Fri, 17 Mar 2017 11:29:22 +0000
User-agent: Mutt/1.6.1 (2016-04-27)

On Fri, Mar 17, 2017 at 08:06:56PM +1100, Brendan O'Dea wrote:
> On 17 March 2017 at 19:55, Chris Green <address@hidden> wrote:
> >> Try mapping it to ^Vu2714.  That worked for me.
> >>
> > That's *exactly* what I have done, it shows correctly (as above) in
> > .vilerc but when I hit F4 in insert mode while editing I see the
> > string â\u009C\0094.  I can insert a ✔ by typing CTRL/V + u + 27 + 14
> > though, it displays OK in vile.
> Don't map it to the *value* of ^Vu2714, map it to that sequence of
> characters.  i.e. your .vilerc should contain a ^V and the following
> characters, *not* the tick character.  Obviously you need to type
> "map! # ^V^Vu2714" when editing .vilerc to get that single literal ^V.
Of course!  ... or at least I think so.  :-)

Anyway it works now, thank you.

Chris Green

reply via email to

[Prev in Thread] Current Thread [Next in Thread]