[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Solved: trying to avoid a segfault

From: Al Joslin
Subject: Solved: trying to avoid a segfault
Date: Thu, 26 Dec 2019 14:12:53 -0500

Hi again,

I recompiled the package with the ./configure --disable-guile flags and now it doesn’t segfault, and works as expected


On Dec 20, 2019, at 12:05 PM, Al Joslin <address@hidden> wrote:

Hello All,

xbindkeys is doing everything I need it to do at the cmdLine but I am having trouble getting it to work programmatically (as root, on the system in question)

I have a touch-screen kiosk (running CentOS 7) that has to “idle” with a full-screen video and then switch back to “active” mode when touched

Calling xbindkeys this way works from a shell that was logged in with XWindows forwarding turned on

DISPLAY=:0 /usr/bin/xbindkeys -f /usr/local/pss/mplayer_xbindkeys.rc

The .rc file is fairly simple (even a little overblown because I don’t know yet which buttons correspond to single or multi-touch)

 b:1 + Release

 b:2 + Release

 b:3 + Release

 b:4 + Release

The error I get when running the above command from the same script that is launching mplayer is:

Dec 19 11:00:24 sg2 kernel: xbindkeys[28518]: segfault at 0 ip 00007f53da4a491c sp 00007ffca96e0ab8 error 4 in libc-2.17.so[7f53da342000+1c3000]

I believe that there are XWindows environment variables, or perhaps even more than that which I am missing in my programmatic invocation

My logged in shell (where the command works) has an env variable XDG_SESSION_ID=8214

That is saying to me that I’ve got to get some kind of additional connection to the XWindows environment, or maybe the HID module?  

Furthermore, (for whatever reason) we are running: Xorg X Server Build 1.20.4 , X windows protocol 11,version 0. No windows manager (just straight xinit)

?? If anyone can suggest how I might keep xbindkeys from segfaulting I’d sure appreciate the help !!

And, I need to do all of this from the shell

Thanks everyone, for your time and attention

Two Additional Bits of Info from the logged in prompt that supports my cmdLine invocation of xbindkeys:

`wmctrl -m` responds with:

Name: N/A
Class: N/A
Window manager's "showing the desktop" mode: N/A

`ps aux | grep X` comes back with :

root     21331  5.0  2.3 342368 78276 tty4     S<sl+ Dec19  56:58 X :0 -allowMouseOpenFail

reply via email to

[Prev in Thread] Current Thread [Next in Thread]