[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [XForms] Canvas / button interaction

From: Jens Thoms Toerring
Subject: Re: [XForms] Canvas / button interaction
Date: Thu, 9 Feb 2012 14:28:23 +0100
User-agent: Mutt/1.5.21 (2010-09-15)

Hi Clive,

On Thu, Feb 09, 2012 at 11:14:59AM +0000, Clive Stubbings wrote:
> I have recently been doing that dreaded periodic fork-lift linux
> update. It always throws up some troublesome issues. This one is
> particularly wierd.
> I have an old app, been working for years. Tried running it on a new
> system and various bits of the gui didn't display right. It looked
> like a 'flush' issue but fl_update_display() did not help.
> . However the issue shows up even if I run the old app on the old
> system but put just the display over the network onto the new
> platform. New platform is Arch Linux. Building against different
> libraries didn't change anything. The arch xforms package is
> 1.0.94pre4-1, I was using something older..
> I boiled it down to the example below. If the canvas object is
> created then the checkbutton does not light when you press it. If
> the canvas object is not created, the check button works fine. I
> believe that the object sees the mouse button press because in the
> bigger app, I could see callbacks happening.
> On my old system this works fine in both cases. So my take is this
> is an X server interaction issue with a new Xorg. The X is X.Org X
> Server 1.11.4
> Release Date: 2012-01-27, X Protocol Version 11, Revision 0.
> Or am I missing something obvious.

Not anything I could see - looks like an absolutely correct
program. Alas, I also can't reproduce it with a slightly
older XOrg version of 1.10.4. And a short look at the code
for drawing the checkbutton also doesn't show anything I
would consider to be strange. But the connection with the
existence of a canvas object is really "interesting". Might
be interesting to look if the draw_checkbutton() function in
checkbut.c is called at all. If it does the first thing I
would suspect is some clipping issues, otherwise something
really strange must be going on. Another thing that could
be interesting to check is if it makes a difference if one
swaps the creation of the canvas and the checkbutton in the

Unfortunately, I won't be able to update to a newer XOrg
version at the moment, so I can't make promises when I will
be able to try to reproduce the problem on my machine.

                           Best regards, Jens
  \   Jens Thoms Toerring  ________      address@hidden
   \_______________________________      http://toerring.de

reply via email to

[Prev in Thread] Current Thread [Next in Thread]