[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX-devel] About templates

From: auxsvr
Subject: Re: [AUCTeX-devel] About templates
Date: Mon, 5 May 2008 15:17:00 +0300
User-agent: KMail/1.9.6 (enterprise 20070904.708012)

On Monday 05 May 2008, David Kastrup wrote:
> address@hidden writes:
> > Hi,
> >
> > I wanted to use templates for latex files, so I tried the solution Ralf
> > Angeli proposed some months ago in this mailing list. The problem with it
> > is that loading auctex 11.85 causes (add-hook 'find-file-hook
> > 'auto-insert) to fail, that is, evaluating find-file-hook when the buffer
> > opens shows no sign of auto-insert and no text is added to the buffer. I
> > managed to work around this by using
> >
> > (add-hook 'find-file-not-found-functions 'auto-insert)
> > (TeX-tex-mode)
> >
> > instead, which works so far, yet doesn't look optimal (actually it causes
> > *scratch* to start in latex-mode). Am I the only one with this problem?
> >
> > By the way, you may count me as a user of the tex-omega mode, although
> > I'm thinking about moving to xetex when it becomes less buggy.
> It is my impression that XeTeX is quite less buggy than pretty much
> everything that has been released as Omega, though I have not tried it
> myself.  LuaTeX, in contrast, is a moving target, albeit a powerful one.

Just tried to xelatex a simple file with unicode text, none of the non-ASCII 
characters appear in text mode, and adding package fontspec crashes xelatex 
every time. This is version 3.141592-2.2-0.996 (Web2C 7.5.6) on opensuse 


reply via email to

[Prev in Thread] Current Thread [Next in Thread]