[Top][All Lists]

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [AUCTeX] PDF2DSC sentinel: Wrong type argument: arrayp, nil

From: José Carlos Santos
Subject: Re: [AUCTeX] PDF2DSC sentinel: Wrong type argument: arrayp, nil
Date: Wed, 25 Nov 2015 23:45:49 +0000
User-agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:38.0) Gecko/20100101 Thunderbird/38.3.0

On 25/11/2015 21:11, Arash Esbati wrote:

No. :-( I use the 64 bit version of Ghostscript and it looks like
preview.el only works with 32 bit Ghostscript.

All of the respective executable names can be customized (by the way:
what kind of stupid idea is it to put the architecture in the executable

I am not sure to have understood you. Do you mean that I may change
some file on my machine in such a way that preview works with
gswin64c.exe instead of gswin32c.exe?

For testing, you could put

(setq preview-gs-command
       (executable-find "gswin64c.exe"))

in your `.emacs' if you have "gswin64c.exe" in your PATH or something

(setq preview-gs-command
        "C:\\Program Files\\gs\\gs9.18\\bin\\gswin64c.exe"))

if not and see if it works.

I tried the first option and it worked. Thanks a lot.

Best regards,

José Carlos Santos

reply via email to

[Prev in Thread] Current Thread [Next in Thread]